Dans ce cours, vous allez apprendre les bases de la formule SI, avec Excel 2019. La formule SI est une des formules les plus utilisée car elle permet de faire énormément de choses !

Si vous avez, dans votre tableau, un résultat dépendant de telle ou telle chose, la formule SI sera sûrement la solution. Elle implique une ou plusieurs conditions, ce qui permet d’avoir différents résultats possible dans une cellule.

Dans cet exemple, vous allez comprendre comment cette formule est structurée et comment elle fonctionne. Je vous donne également une astuce afin de ne jamais vous tromper lorsque vous l’utilisez ! Au début, on est vite perdu, mais avec cette astuce, vous ne le serez plus.

La formule SI ?

Lorsque vous aurez compris son fonctionnement, vous allez vous apercevoir que vous pouvez l’uiliser partout afin de gagner beaucoup de temps ! Dans un des prochains cours, vous allez voir comment faire une facture ou un devis et là, vous verrez le potentiel de cette formule. Avec celle-ci, nous pouvons imbriquer plusieurs formules, ce qui permet de l’utiliser partout !

Sa structure

Comme toute formule, il faut commencer par égal (=), puis, le nom de la formule, c’est à dire SI et enfin les parenthèses et son contenu. Ce qui nous donne : =SI(Question;Oui;Non). On commence toujours en premier par la question (qui concerne la condition), par exemple : est-ce la moyenne est supérieure ou égale à 10. Puis, le premier point virgule veut dire « Alors » et on met la réponse par Oui. Enfin, on met le deuxième point vircule qui veut dire « Sinon » et on met la réponse par Non. Dans tous les cas, si la réponse contient du texte et non des chiffres, il faut le mettre entre guillemets.

Une fois que vous avez compris sa structure, vous pourrez vous amuser avec cette formule qui est utilisable partout ! De plus, vous pouvez aussi combiner d’autres formules avec la formule SI. Par exemple : =SI(F1= « Tournesol » ;somme(B4:B22);24). Dans ce cas, cela donne : si F1 est égal à Tournesol alors tu me mets la somme des cellules de B4 à B22, sinon, tu mets 24. L’important, c’est que cela soit logique, que vous respectez bien la structure de chaque formules utilisées et que vous n’oubliez pas de fermer toutes les parenthèses. Si vous oubliez de fermer une parenthèse, Excel va vous le signaler et vous proposer une correction : c’est à vous de voir si elle vous convient ou pas !

La formule SI à l'infini :

Comme nous l’avons vu, nous pouvons imbriquer plusieurs formules avec la formule SI. Mais il est également possible d’imbriquer plusieurs formules SI ! Exemple : =SI(F1= «  » ; «  » ;SI(F1= « Tournesol » ;somme(B4:B22);24). Ce qui nous donne : si F1 est vide, alors tu ne mets rien, sinon si F1 est égal à Tournesol, alors tu fais la somme de B4 à B22, sinon tu mets 24.

Après, cela dépend bien entendu du contenu de votre tableau, mais il n’y a pas de limites, il faut bien respecter la logique de vos questions !

Les cours gratuits vous sont utiles ?

Si vous trouvez que je fais de bons cours et qu’ils répondent à vos questions (ce qui est le cas d’après vos commentaires et je vous en remercie), alors n’hésitez pas à ma laisser un Tip. Pour cela, cliquez ici.

 

N’hésitez pas non plus à vous abonner à la chaîne Tuto Patrick – Informatique et à activer les notifications afin de ne pas louper les prochains cours gratuits !

Partager ce cours :

Partager sur email
Partager sur facebook
Partager sur linkedin
Partager sur pinterest
Partager sur telegram
Partager sur tumblr
Partager sur twitter
Partager sur whatsapp